Build question

Edward Tomasz Napierala trasz at FreeBSD.org
Mon Dec 3 04:52:31 PST 2007


On 1130T1719, Rick wrote:
> Hello to anyone who may be here -
> 
> In trying to build Nopareil on Linux (Fedora Core 6/gcc 4.1.1/scons v0.97)
> I get the following error:
> 
> 
>      gcc -o build/posix/csim.o -c -Wall -g -pthread -D_GNU_SOURCE=1
>      -D_REENTRANT "-D{'DEFAULT_PATH': '/usr/local/lib/nonpareil'}"
>      -Ibuild/posix -Isrc -Ibuild/common -I/usr/include/gtk-2.0
>      -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0
>      -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0
>      -I/usr/lib/glib-2.0/include -I/usr/include/freetype2
>      -I/usr/include/libpng12 -I/usr/include/libxml2 -I/usr/include/SDL
>      src/csim.c
> 
>      <command line>:1:1: error: macro names must be identifiers
>      scons: *** [build/posix/csim.o] Error 1
>      scons: building terminated because of errors.

You can try the workaround used in FreeBSD port:

http://www.freebsd.org/cgi/cvsweb.cgi/ports/emulators/nonpareil/files/patch-src_SConscript?rev=1.5

-- 
If you cut off my head, what would I say?  Me and my head, or me and my body?



More information about the Nonpareil-users mailing list